Tech

Cyberpunk 2077 Vulnerability Found

[ad_1]

CD PROJEKT RED, the developer of Cyberpunk 2077, acknowledged that the PC platform has a vulnerability that paves the way for remote code execution. The company warned the players about the mods and special registration files.

CD PROJEKT RED’s long-awaited game Cyberpunk 2077Unfortunately, it was far from meeting the expectations of the game world. However, the game continues to be played thanks to its mod support and mod tools. Today, players who want to use Cyberpunk 2077 mods on the PC platform, from CD PROJEKT RED an important warning came.

The developer company is currently using the mods we downloaded from the internet in the Tweet shared on Twitter. that it may be dangerous for our safety shared a warning. Accordingly, a vulnerability discovered in the game can be seen by some people through mods. can be used maliciously case. The entire Tweet shared by the company was as follows:

Remote code can be run on PCs:

cd project red

Be careful if you want to use Cyberpunk 2077 mods / custom registers on PC. An external DLL file that can be used to run code on PCs. security bug We were informed about. Problem AS SOON AS POSSIBLE will be resolved. For now, please avoid using files from unknown sources.

Problem mentioned by CD PROJEKT RED, member of Red Tools mod team this weekend PixelRickyRick and Reddit user Romulus_Is_Here It was voiced by. Although the vulnerability is thought to be limited to the PC version of the game only, PixelRickyRick says PlayStation 4 version He had announced that he had a security flaw.

RELATED NEWS

Games to be added to Xbox Game Pass in the first half of February announced

For the vulnerability in the game, a solution was found by one of the most used modes of Cyberpunk 2077. Improving the performance of the game and fixing bugs in the game Cyber Engine Tweaks mod included an innovation that fixes the vulnerability in its latest version. If you want to download the mod to this link You can reach the mod page by clicking.

Source :
https://www.pcgamer.com/cd-projekt-warns-against-using-cyberpunk-2077-mods-until-a-serious-security-flaw-is-fixed/

[ad_2]